ZIL deposits and withdrawals maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Mar 27, 2023 - 12:36 UTC
Investigating
We are currently investigating this issue.
Posted Mar 13, 2023 - 16:29 UTC
This incident affected: Crypto Withdrawals (ZIL) and Crypto Deposits (ZIL).